View Issue Details

IDProjectCategoryView StatusLast Update
0000619filegeneralpublic2017-05-26 15:45
ReporterFrederick Grose 
Assigned ToChristos Zoulas 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Platformx86_64OSFedoraOS Version25, 26
Product Version5.30 
Target VersionFixed in VersionHEAD 
Summary0000619: Fails to id ISO 9660 image file
DescriptionExample:
$ file -b /WD-ext4/Fedora/Fedora-Workstation-Live-x86_64-25-1.3.iso
DOS/MBR boot sector; partition 2 : ID=0xef, start-CHS (0x3ff,254,63), end-CHS (0x3ff,254,63), startsector 91688, 10640 sectors
TagsNo tags attached.

Relationships

Activities

Christos Zoulas

Christos Zoulas

2017-05-25 21:02

manager   ~0001524

what does file -k say? Perhaps it is both ...
Frederick Grose

Frederick Grose

2017-05-25 21:16

reporter   ~0001525

$ file -bk /WD-ext4/Fedora/Fedora-Workstation-Live-x86_64-25-1.3.iso
DOS/MBR boot sector; partition 2 : ID=0xef, start-CHS (0x3ff,254,63), end-CHS (0x3ff,254,63), startsector 91688, 10640 sectors DOS/MBR boot sector ISO 9660 CD-ROM filesystem data (DOS/MBR boot sector) 'Fedora-WS-Live-25-1-3' (bootable) Apple Driver Map, blocksize 2048, blockcount 37008, devtype 0, devid 0, driver count 0, contains[@0x200]: , contains[@0x400]: , contains[@0x600]: , contains[@0x800]: Apple Partition Map, map block count 3, start block 1, block count 4, name Apple, type Apple_partition_map, valid, allocated, contains[@0xA00]: , contains[@0xC00]: , contains[@0xE00]: , contains[@0x1000]: Apple Partition Map, map block count 3, start block 22922, block count 2660, name EFI, type Apple_HFS, valid, allocated, readable, writable FoxPro FPT, blocks size 37008, next free block index 1163003904\012- data

Yes, there are multiple partitions. This seems to be a change from previous behavior where partition 1 was reported. Partition 2 in any case is an unexpected choice.
Christos Zoulas

Christos Zoulas

2017-05-25 21:22

manager   ~0001526

Yes, I expected that. It seems that the strength changed between the two versions file.. Can you try file -bkl with the two different versions of file and see if they changed?
Frederick Grose

Frederick Grose

2017-05-25 22:18

reporter   ~0001527

# file -v
file-5.25
magic file from /etc/magic:/usr/share/misc/magic

# file -br /run/WD-ext4/Fedora/Fedora-Workstation-Live-x86_64-25-1.3.iso
ISO 9660 CD-ROM filesystem data (DOS/MBR boot sector) 'Fedora-WS-Live-25-1-3' (bootable)

# file -bkl /run/WD-ext4/Fedora/Fedora-Workstation-Live-x86_64-25-1.3.iso
https://gist.github.com/FGrose/4a80eb5d72e80d63de673089f1e21f29#file-file-5-25-bkl-txt

$ file -v
file-5.30
magic file from /etc/magic:/usr/share/misc/magic

$ file -br /WD-ext4/Fedora/Fedora-Workstation-Live-x86_64-25-1.3.iso
DOS/MBR boot sector; partition 2 : ID=0xef, start-CHS (0x3ff,254,63), end-CHS (0x3ff,254,63), startsector 91688, 10640 sectors

$ file -bkl /WD-ext4/Fedora/Fedora-Workstation-Live-x86_64-25-1.3.iso > /WD-ext4/Fedora/file-5.30-bkl.txt
https://gist.github.com/FGrose/4a80eb5d72e80d63de673089f1e21f29#file-file-5-30-bkl-txt
Christos Zoulas

Christos Zoulas

2017-05-26 14:27

manager   ~0001532

I think this is the diff that broke it:
@@ -539,8 +539,6 @@
 >>>514 string !HdrS
 # not BeOS
 >>>>422 string !Be\ Boot\ Loader
->>>>>32769 string CD001
->>>>>>0 use cdrom
 # jump over BPB instruction implies DOS bootsector or AdvanceMAME mbr
 >>>>>0 ubelong&0xFD000000 =0xE9000000
 # AdvanceMAME mbr

Can you put the first couple of megs of the image somewhere so I can test?
thanks!
Frederick Grose

Frederick Grose

2017-05-26 15:10

reporter   ~0001534

$ dd if=/WD-ext4/Fedora/Fedora-Workstation-Live-x86_64-25-1.3.iso of=/WD-ext4/Fedora/Fedora-Workstation-Live-x86_64-25-1.3.iso.2MiB bs=2MiB count=1

http://people.sugarlabs.org/fgrose/Fedora-Workstation-Live-x86_64-25-1.3.iso.2MiB
Christos Zoulas

Christos Zoulas

2017-05-26 15:45

manager   ~0001535

Thanks, bumped cdrom strength back up.

Issue History

Date Modified Username Field Change
2017-05-25 16:05 Frederick Grose New Issue
2017-05-25 21:02 Christos Zoulas Note Added: 0001524
2017-05-25 21:16 Frederick Grose Note Added: 0001525
2017-05-25 21:22 Christos Zoulas Note Added: 0001526
2017-05-25 22:18 Frederick Grose Note Added: 0001527
2017-05-26 14:27 Christos Zoulas Note Added: 0001532
2017-05-26 15:10 Frederick Grose Note Added: 0001534
2017-05-26 15:44 Christos Zoulas Assigned To => Christos Zoulas
2017-05-26 15:44 Christos Zoulas Status new => assigned
2017-05-26 15:45 Christos Zoulas Status assigned => resolved
2017-05-26 15:45 Christos Zoulas Resolution open => fixed
2017-05-26 15:45 Christos Zoulas Fixed in Version => HEAD
2017-05-26 15:45 Christos Zoulas Note Added: 0001535