View Issue Details

IDProjectCategoryView StatusLast Update
0000617filegeneralpublic2017-05-24 17:35
Reporternochiel 
Assigned ToChristos Zoulas 
PriorityhighSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64 OSGNU/LinuxOS Version4.10.13-1-ARCH
Product Version5.30 
Target VersionFixed in VersionHEAD 
Summary0000617: file does not report the correct filetype(s) for a polyglot PDF.
DescriptionConsider: https://archive.org/download/pocorgtfo13/pocorgtfo13.pdf
- This file is a polyglot pdf.
- `file -ki` however reports: `text/plain\012- application/octet-stream; charset=iso-8859-1` which is not quite correct.
- A side-effect of this is that any script/application using `file(1)`to determine the file's type will fail to see it as a pdf (e.g. the [Zathura reader](https://bugs.pwmt.org/project/zathura/issue/677) should happily read the pdf but doesn't because it uses `file(1)` to determine which file-type plugin to use).
Steps To Reproduce`file -ki pocorgtfo13.pdf`
Tagsfeature

Relationships

Activities

Christos Zoulas

Christos Zoulas

2017-05-24 17:35

manager   ~0001521

Fixed, thanks.

Issue History

Date Modified Username Field Change
2017-05-16 19:24 nochiel New Issue
2017-05-16 19:24 nochiel Tag Attached: feature
2017-05-24 17:35 Christos Zoulas Assigned To => Christos Zoulas
2017-05-24 17:35 Christos Zoulas Status new => assigned
2017-05-24 17:35 Christos Zoulas Status assigned => resolved
2017-05-24 17:35 Christos Zoulas Resolution open => fixed
2017-05-24 17:35 Christos Zoulas Fixed in Version => HEAD
2017-05-24 17:35 Christos Zoulas Note Added: 0001521